Zend Guard 6 Does Not Start on OS X 10.9 Mavericks

Overview

When trying to launch Zend Guard 6 on Apple OS X 10.9 (Mavericks), the following error message is displayed:

Solution

Download and apply a patch to Zend Guard that solves this issue.

Instructions

  1. Download Patch_Zend_Guard_for_Mavericks.zip.
  2. Extract the patch application from the downloaded archive (if you are using Safari, the extracted application is located in the Downloads directory).
  3. Launch the patch application.
    You will be prompted to select the location of the  Zend Guard application.
    If a warning that Java 6 is not installed on your system is displayed, download and install Apple's Java 6 package (the download page will be opened automatically in your browser).
  4. Select the Zend Guard application from the list, or by using the Browse button in the dialog (the most likely location is /Applications/Zend Guard 6.app).
  5. If the patch was applied correctly, a confirmation dialog is displayed.
Note:
This patch inserts path-cpecific code into Zend Guard. If you move the Zend Guard application to a different location, it will cease to work. If you do need to move Zend Guard, re-apply the patch at the new location.

 

This video shows the patching process:

 

 

Expected Result

After the patch is applied, you will be able to start Zend Guard correctly with unimpaired functionality.